(}}SymCom MODEL CIO-MLPII-PR

Motor Protection & Controls Since 1974 PROFlBUS COMMUNICATIONS MODULE
PROGRAMMING GUIDE

HAZARDOUS VOLTAGES MAY BE PRESENT DURING INSTALLATION.
Electrical shock can cause death or serious injury.
Installation should be done by qualified personnel following all national, state and local electrical codes.

BE SURE POWER IS DISCONNECTED PRIOR TO INSTALLATION!
FOLLOW NATIONAL, STATE AND LOCAL CODES.
READ THESE INSTRUCTIONS ENTIRELY BEFORE INSTALLATION.

The CIO-MLPII-PR Module is a convenient and cost-effective Profibus interface capable of providing
discrete control and monitoring of motor starters, drives, and other devices over a Profibus network.
The CIO-MLPII-PR is designed to provide the following benefits in both new and existing
installations:

§ reduced field wiring

§  greater operator efficiency

§  ease in system startup and commissioning

The CIO-MLPII-PR Profibus module can be DIN rail mounted, or mounted directly to a back panel.
The CIO-MLPII-PR’s compact size, ease of wiring and Profibus communications capability makes the
use of traditional discrete devices on Profibus cost-effective and simple.

The CIO-MLPII-PR Module is compatible with Square D’'s Model MLPII overload relay. It simply
connects to the side of the MLPIlI and permits remote monitoring and control of the MLPII over a
Profibus network.

CONNECTIONS

. Mount the CIO-MLPII-PR in a convenient location in a properly rated enclosure. The CIO-MLPII-
PR can be mounted to a back panel using screws or can be snapped onto DIN rail.

. Connect the five Profibus wires to the 5-pin connector on the front of the CIO-MLPII-PR Module.
24VDC should be connected to V+ and V-. Connect the other three wires to A, B and Shield.

. The PBus LED indicates communication is established between the CIO-MLPII-PR and the
Profibus master, and OLC indicates communication is established with the MLPII overload.

. Connect the Profibus SUB-D connector to the Profibus network.
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DIAGNOSTIC INDICATOR LIGHTS

The unit is energized when power is applied between V+ and V- on the connector. The PBus and
OLC lights will flash until communication is established. The PBus communication status indicator
light will come on steady when a Profibus master is communicating with the unit. The OLC
communications status indicator light will come on steady when it is communicating to an MLPII
overload relay.

OPERATION

The CIO-MLPII-PR Module is a DP-VO device. Cyclical I/O is supported for the transfer of input and
output information.

PROFIBUS NETWORK CONFIGURATION

Cable Routing
Follow these general cable-routing guidelines:

Avoid areas of high temperature, moisture, vibration, or other mechanical stress.
Secure the cable where necessary to prevent damage.

Use cable ducts, raceways, or other structures to protect the cable.

Never route cables over or around sharp edges.

Avoid sources of electrical interference that can induce noise into the cable. Use the maximum
practicable separation from such sources.

Maintain a minimum separation of 3.3 ft. (1m) from the following equipment:

0 air conditioners and large blowers

elevators and escalators

radios and televisions

intercom and security systems

fluorescent, incandescent, and neon lighting fixtures

O ooo

Maintain a minimum separation of 10 ft. (3m) from the following equipment:

0 Line and motor power wiring
o Transformers

o0 Generators

o Alternators

Terminating Resistors

+5V—_|_

Profibus segments must be bus terminated as shown.
390Q
Line B
FIGURE 3: Bus Termination ]
2200
Line A
390Q
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Profibus Cable

The Profibus Cable must be connected as follows:

Pin | Signal Description Specification
Cable  [Device

1 |— —-— Not used

2 |— -— Not used

3 RxD/TxD-P | Receive/Transmit data; line B (red) Mandatory

4 |CNTR-P Control of repeater direction Optional®

5 DGND Data ground (reference voltage to VP) Mandatory

7 |— — — Not used

6 |VvP' Power supply +5V (e.g. bus termination) | Mandatory

8 RxD/TxD-N |Receive/Transmit data; line A (green) Mandatory

; Minimum current capability isllomA o ] ) o
These signals should be provided by the device if converters from RS-485 to fiber optic transmission are
to be supported.

FIGURE 3: 9-Pin Sub-D
Connector Pin Assignment
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SOFTWARE CONFIGURATION

Import GSD File into the SyCon Software
Open SyCon software and select File > CopyGSD. Import the file SMCMOA9D.GSD.

£ SyCon - [C:\Program Files\Synergetic\SyComProjectest32x2. pb]
v

Tnsert Settings Tools Window Hep
=Ty
colro

[IESTR

Master1
saton ascress 1
DPMaster “40CRP 81100

FROFIBUS ___ iconri Mode

Insert Devices onto the Network

Insert Slave @
Slave Filter
Vendor | B Master |1 /140 CRP 11 00 - 0
Slave type | Al h Cancel
Availale slaves Selected slaves
Add >
Add Al >
<< Remave All
<< Remove
Wendor name SpmCom Station address
Ident number 00450 Description

G5D file name SMCMOA3D.GSD
GSD Revision Rev. 1

Add devices to the network by selecting Insert > Master and/or Insert > Slave or click the Insert
Master or Insert Slave buttons. Select the device to add and click the Add>> button, then OK.
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Configure the Slave(s)

Select the slave and choose Settings > Slave Configuration or double click on the slave to open the
Slave Configuration dialog box.

Slave Configuration §|

Gereral

Device CIO-MLPIFR Station address |2
Deseription  [Slave2 Cancel
IV Activate device in actual configuration

¥ Enable walchdag canliol GSDfle  SMEMOASD.GSD _ PaameeDals. |
Max length of in-/output data 64 Bpts  Lenathofin-foutputdata 22 Byte y

Mak, lergth of input data 32 Boe  Lengthofinpul data 2 B pssigned s
Max. length of output data 32 Bpe Length of output data 2 Byte | Station address 1
Mat. number of modules 1 Number of modules 1 -
Moduls [mapucs [ouepucsin/oue [Tdencitier 4| | [177400RP 811 00 =
DeczDd4 2 Bytes Out, © 2 Word Z Byhe OxZl, OxS1
Words In T
Actual slave
Recz50 z Bytes Out, 3 10 z Byte 0x21, 0x53 Sl L ees
Words In Word
Slave2
Recz3? 2 Bytes Out, 14 15 z Byte OxZl, OxSE
Words In Word & 2/ CIOMLPI-PR 5

Slodldz Module [Sywbol [type|T Addr. [T Len. [Type o Adde. [0 Lem || 4o iy

0 1 BecZ50 Z Modulel 0B o z

0 2 Rec250 ZModulel IN @ 10 Remove Maduls
Insert Module

Set the correct Station address. Select the correct I/O module in the Actual slave menu and set
any other options in the Slave Configuration window. Append the 1/0 module from the Module list
in the middle of the window by double-clicking it or by highlighting it and clicking Append Module. It
will be added to the lower window which places it into a slot.

Still in the Slave Configuration window click the Parameter Data...button—all parameter data are
displayed in hex. Click Common—the common parameter data is displayed. Double-click the Input
record number and enter the value of the input record, to match the chosen module on the previous
screen.

»

|2 syCon - [CoProgram Hiles\SynergeticisyConwroject 2ot - |=]x]
% :
O=d £ ?
St %[ o

M Desciptin  Conmen Paranete Data

"

M

"

: Daayge  Unignede & ]

i et

P4 [ WiemStucTure | invske  0fdec] [ |

= Manvake 255 dec) Hex

I Foicsensd

n Vel dc

i

o u

B |

o I @

o 1

nsen Hode
5] |

ooy press Tt FROFDUS  Corighods
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% e Edt View Insrt Settrgs Tools Window Help

Ol | |2

EAEE
Master1
statonadoress 1
DPiater 140 CRP 81100
Slave2

— E[HEm\l' et ot N

P Siave CICMLPI-PR

Dorlelp pressTt PROTIEUS _[Corvig fods

Export the configuration for import into Concept or other PLC configuration software:

1) Select the Master in the visual network picture.
2) Save the network.
3) Select File > Export > ASCII to save the cnf file.
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Import the Network Configuration into the PLC

CRP-811-00 (Profibus DP) x|
Master Slave
Busfddi 1 BackplaneSiot: 4 [ Add Upload Info
Cear | import. Peset. | Paams.. | | | \
Busdr. | Slave Type | Modue | InType Infier | InEnd | OutType | 0]
2 |coem
1 UNTIE [ ] 300001 300015 BOOL [~
| [
oK | Cancel | Help | I

When Concept software is used, follow these steps to import the network configuration:

1. Open a project.

No orwN

CYCLICAL INPUT RECORDS

Select Project > Configurator and double-click /0O Map.
Click the edit button next to the PLC.
Select the Profibus scanner and click the Params button.

Click the Import... button and choose the desired .cnf file.

In the scanner configuration window assign registers to all /O data for all devices.
Continue clicking OK and YES in the I1/0O Map dialog box to update the changes.

Record 204
Byte.Bit |Name Description

0-1 Average Current
2. MLP20OPRSTAT
2.0 Out A
2.1 Out B
2.2 Running
2.3 Modbus Comm Loss
2.4 Fault
25 Overcurrent
2.6 Ground Fault
2.7 Warning
3.0 Trip Relay Closed
3.1 In1
3.2 In2
3.3 In3
34 In4
35 PTC Warning
3.6 PTC Trip
3.7 PTC Short

Record 208

Byte.Bit [Name [Description
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0-8 | Proprietary
Record 250
Byte.Bit |Name Description

0-1 Current / OC Setpoint % current of oc setpoint
2-3 Average Current
4-5 IC
6-7 1B
8-9 1A

10-11 CuB

12-13 Thermal Capacity

14-15 | GF

16-17 MLP20OPRSTAT
16.0 Out A

16.1 OutB

16.2 Running

16.2 Modbus Comm Loss
16.4 Fault

16.5 Overcurrent

16.6 Ground Fault

16.7 Warning

17.0 Trip Relay Closed
171 In1

17.2 In 2

17.3 In3

17.4 In 4

17.5 PTC Warning

17.6 PTC Trip

17.7 PTC Short

18-19 Fault Status same as Modbus 40408
18.0 Reverse Phase
18.1 PTC Overtemp
18.2 Reserved

18.3 Undercurrent

18.4 Overcurrent

18.5 Ground Fault

18.6 Current Unbalance
18.7 Single Phase

19.0 Reserved

19.1 PTC Shorted

19.2 Internal Error

19.3 No AC Power

19.4 Reserved

19.5 Reserved

19.6 Reserved

19.7 Reserved
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Record 232

Byte.Bit |Name Description
0-1 Current / OC Setpoint % current of OC setpoint
2-3 Average Current
4-5 IC
6-7 1B
8-9 1A
10-11 CuB
12-13 Thermal Capacity
14-15 | GF
16-17 RD1
18-19 RD2
20-21 RD3
22-23 MLP20OPRSTAT
22.0 Out A
22.1 OutB
22.2 Running
22.3 Modbus Comm Loss
22.4 Fault
22.5 Overcurrent
22.6 Ground Fault
22.7 Warning
23.0 Trip Relay Closed
23.1 In1
23.2 In 2
23.3 In3
23.4 In 4
235 PTC Warning
23.6 PTC Trip
23.7 PTC Short
24-25 Last 4 faults same as Modbus 40425
24.0-24.3 |Last Fault
24.4-24.7 |2nd last fault
25.0-25.3 [3rd last fault
25.4-25.7 |4th last fault
26-27 Fault Status same as Modbus 40408
26.0 Reverse Phase
26.1 PTC Overtemp
26.2 Reserved
26.3 Undercurrent
26.4 Overcurrent
26.5 Ground Fault
26.6 Current Unbalance
26.7 Single Phase
27.0 Reserved
27.1 PTC Shorted
27.2 Internal Error
27.3 No AC Power
274 Reserved
275 Reserved
27.6 Reserved
27.7 Reserved
28-29 Holdoff Status same as Modbus 40410
28.0 Reverse Phase
28.1 Thermal Capacity Not enough thermal capacity available
28.2 PTC Overtemp
28.3 PTC Shorted
28.4 Test Trip (Local) Local reset button
28.5 Test Trip (Remote) remote reset button
28.6 Reserved
28.7 Reserved
29.0 Reserved
29.1 Reserved
29.2 Internal Error
29.3 No AC Power
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29.4 Reserved

29.5 Reserved

29.6 Internal Error

29.7 Internal Error EEPROM checksum

CYCLICAL OUTPUT

Cyclical Messages, Output / Control

Byte.Bit |Name Description
0.0 Out B/ Run Reverse 0=0ff, 1=On
0.1 Off 1=turn Out A & B Off
0.2 Out A / Run Forward 0=0ff, 1=On
0.3 unused
0.4 Overload Test 1=Force Trip
0.5 unused
0.6 Reset 1=Reset fault relay
0.7 unused

10

1/07



DIMENSIONS

DEPLUGGABLE
TERMINAL BLOCK M

|

PROFIBUS

SUB-D CONNECTOR

M
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CIO-MLPII-PR SPECIFICATIONS

Power Requirements

Voltage 12-24VDC

Current 150mA (max.)

Power 3.6 Watts (max.)
Weight 14 oz.
Enclosure Polycarbonate

Terminal (depluggable terminal block)

Torque 4.5 in.-lbs. (max.)
Wire AWG 12-20 AWG

Safety Marks
UL UL508 (File #E68520)
CSA Cc222

Standards Passed

Electrostatic Discharge (ESD)

IEC 1000-4-2, Level 3, 6kV contact, 8kV air

Radio Frequency Immunity, Radiated

159 MHz, 10V/m

Fast Transient Burst

IEC 1000-4-4, Level 3, 4 kV input power

Hi-Potential Test

Meets UL508 (2 x rated VV +1000V for 1 minute)

Environmental

Temperature Range

Ambient Operating: -20° to 70°C (-4° to 158°F)
Ambient Storage: -40° to 80°C (-40° to 176°F)

Class of Protection

1P20, NEMA 1 (Finger Safe)

Relative Humidity

10-95%, non-condensing per IEC 68-2-3
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